DPF Template Not Working on OSX

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

DPF Template Not Working on OSX

Chris Share
Hi Folks,


I came across Christopher Arndt's DISTRHO Plugin Framework effect template and would like to use it on OSX. Cookiecutter sets up the project as expected. Once it's downloaded I set "MACOS=true" in Makefile.mk. When I run "make" I get the following error:

/Applications/Xcode.app/Contents/Developer/usr/bin/make -C dpf/dgl
Makefile.mk:104: *** OpenGL missing, cannot continue.  Stop.
make: *** [libs] Error 2


I'm using Xcode 6.2 on OS X 10.9.5.

Cheers,

Chris
_______________________________________________
Linux-audio-dev mailing list
[hidden email]
http://lists.linuxaudio.org/listinfo/linux-audio-dev
Reply | Threaded
Open this post in threaded view
|

Re: DPF Template Not Working on OSX

Christopher Arndt
Am 11.10.2016 um 14:03 schrieb Chris Share:
> I set "MACOS=true" in Makefile.mk. When I run "make" I get the following error:
>
> /Applications/Xcode.app/Contents/Developer/usr/bin/make -C dpf/dgl
> Makefile.mk:104: *** OpenGL missing, cannot continue.  Stop.
> make: *** [libs] Error 2

I never tested DPF under OS X, but my guess is that you need to add the
location of the OS X OpenGL headers and libraries to CFLAGS resp. LDFLAGS.

Chris



_______________________________________________
Linux-audio-dev mailing list
[hidden email]
http://lists.linuxaudio.org/listinfo/linux-audio-dev

signature.asc (980 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: DPF Template Not Working on OSX

Filipe Coelho
On 11.10.2016 14:22, Christopher Arndt wrote:
> Am 11.10.2016 um 14:03 schrieb Chris Share:
>> I set "MACOS=true" in Makefile.mk. When I run "make" I get the following error:
>>
>> /Applications/Xcode.app/Contents/Developer/usr/bin/make -C dpf/dgl
>> Makefile.mk:104: *** OpenGL missing, cannot continue.  Stop.
>> make: *** [libs] Error 2
> I never tested DPF under OS X, but my guess is that you need to add the
> location of the OS X OpenGL headers and libraries to CFLAGS resp. LDFLAGS.

DPF author here..


Under OSX you need to use:
$ make MACOS=true

If you're using gcc-4.2 you should use:
$ make MACOS_OLD=true


Hope that works.
_______________________________________________
Linux-audio-dev mailing list
[hidden email]
http://lists.linuxaudio.org/listinfo/linux-audio-dev
Reply | Threaded
Open this post in threaded view
|

Re: DPF Template Not Working on OSX

Chris Share
Using "make MACOS=true" fixed the problem.

Thanks!




----- Original Message -----
From: Filipe Coelho <[hidden email]>
To: [hidden email]
Sent: Tuesday, 11 October 2016, 23:24
Subject: Re: [LAD] DPF Template Not Working on OSX

On 11.10.2016 14:22, Christopher Arndt wrote:
> Am 11.10.2016 um 14:03 schrieb Chris Share:
>> I set "MACOS=true" in Makefile.mk. When I run "make" I get the following error:
>>
>> /Applications/Xcode.app/Contents/Developer/usr/bin/make -C dpf/dgl
>> Makefile.mk:104: *** OpenGL missing, cannot continue.  Stop.
>> make: *** [libs] Error 2
> I never tested DPF under OS X, but my guess is that you need to add the
> location of the OS X OpenGL headers and libraries to CFLAGS resp. LDFLAGS.

DPF author here..


Under OSX you need to use:
$ make MACOS=true

If you're using gcc-4.2 you should use:
$ make MACOS_OLD=true


Hope that works.

_______________________________________________
Linux-audio-dev mailing list
[hidden email]
http://lists.linuxaudio.org/listinfo/linux-audio-dev
_______________________________________________
Linux-audio-dev mailing list
[hidden email]
http://lists.linuxaudio.org/listinfo/linux-audio-dev