Delta 1010 trouble, almost working

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Delta 1010 trouble, almost working

Kevin Cosgrove-3
Hi folks,

I have a Delta 1010 (not LT) that works on one computer, but not another.

Working means that when I use mudita24 (on LinuxMint 19.3) then all of the line inputs work according to the meters, and follow the input signal.

Not working means that when I use envy24control (on Fedora 27) then all of the meters are pegged at the top. envy24control is the predecessor of mudita24. envy24control has worked for me in the past, but on a computer that doesn't exist anymore.

Each computer has its own PCI card for the 1010. But, the experiment was conducted with the same 1010 taking turns on each computer.

Anyone got some debugging ideas for this? I suppose someone's going to tell me to swap the cards between the computers. Yes, I'll do that. I was hoping to find some setting that automatically works on Mint that's not set the same on Fedora.

Thanks all!



_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|

Re: Delta 1010 trouble, almost working

Len Ovens
On Sat, 16 May 2020, Kevin Cosgrove wrote:

> I have a Delta 1010 (not LT) that works on one computer, but not another.
>
> Working means that when I use mudita24 (on LinuxMint 19.3) then all of the
> line inputs work according to the meters, and follow the input signal.
>
> Not working means that when I use envy24control (on Fedora 27) then all of
> the meters are pegged at the top. envy24control is the predecessor of
> mudita24. envy24control has worked for me in the past, but on a computer
> that doesn't exist anymore.

running mudita24 and envy24control side by side on a buntu 20.04 (latest
libs etc.) and both work for my Delta66. So I don't think the version of
envy24control matters. In your analog volume tab, the mudita24 app shows
-inf to +18 and I find 0 works quite well. Envy24control on the other
hand, goes from 0 to 164 (ADCs in both cases, the DACs are different). The
correct setting in that case seems to be 127. It may help to install
envy24control on your mint machine (alsa-tools package) for an easier
reference for setting things the same or mudita24 on the Fedora box.
Mudita24 is much better in my opinion. It seems on the windows app there
is a softswitch that sets things to +4 or -10... it seems that all that
does is to level controls and indications to a different spot.

> Each computer has its own PCI card for the 1010. But, the experiment was
> conducted with the same 1010 taking turns on each computer.
>
> Anyone got some debugging ideas for this? I suppose someone's going to tell
> me to swap the cards between the computers. Yes, I'll do that. I was hoping
> to find some setting that automatically works on Mint that's not set the
> same on Fedora.

If using the same control app on both machines does not help (alsamixer
and qasmixer also work) the it is indeed time to try the same card  in
each machine.

Hmm, the meter settings in envy24control are odd too. I think I would be
inclined to run jack and send the inputs to meterbridge or similar for a
"second opinion". Even pavucontrol should show what the levels it sees
are (without jack).

It is too bad the ice1712 has not been used with PCIe cards, it may not be
the best but is certainly better than USB 2.0 audio in some ways.

--
Len Ovens
www.ovenwerks.net

_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user