Drumstick libs 1.1.3 and VMPK 0.7.2 Released

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Drumstick libs 1.1.3 and VMPK 0.7.2 Released

Pedro Lopez-Cabanillas
Drumstick Libraries 1.1.3

Drumstick is a set of MIDI libraries using C++/Qt5 idioms and style.
Includes a C++ wrapper around the ALSA library sequencer interface: ALSA
sequencer provides software support for MIDI technology on Linux. A
complementary library provides classes for processing SMF (Standard MIDI
files: .MID/.KAR), Cakewalk (.WRK), and Overture (.OVE) file formats. A
multiplatform realtime MIDI I/O library is also provided for Linux,
Windows, and Mac OSX.

Changes for v1.1.3
* Fixed ticket #14: migration to CMake's GNUInstallDirs,
  deprecated LIB_SUFFIX, use CMAKE_INSTALL_LIBDIR instead if required
* Fixed ticket #16: drumstick-file neverending loop with bad MIDI files
* Fixed ticket #17: macos CoreMIDI.framework bad name case
* drumstick-rt: fluidsynth module renamed and optionally available again

Compilation minimum requirements for all platforms: CMake 3.1 and Qt 5.7

Copyright (C) 2009-2019, Pedro Lopez-Cabanillas. License: GPL v2 or later

Project web site
http://sourceforge.net/projects/drumstick

Online documentation
http://drumstick.sourceforge.net/docs/

Downloads
http://sourceforge.net/projects/drumstick/files/1.1.3/


Virtual MIDI Piano Keyboard (VMPK) 0.7.2

Virtual MIDI Piano Keyboard is a MIDI events generator and receiver. It
doesn't produce any sound by itself, but can be used to drive a MIDI
synthesizer (either hardware or software, internal or external). You can
use the computer's keyboard to play MIDI notes, and also the mouse. You can
use the Virtual MIDI Piano Keyboard to display the played MIDI notes from
another instrument or MIDI file player.

Changes for v0.7.2
* Fixed ticket #52: macOS mojave dark mode enabled
* Fixed ticket #53: complain at startup if a default drumstick-rt
  backend is missing
* Fixed ticket #55: problem with the trackpad in mac laptops
* Fixed ticket #57: removed all Google+ links
* Fixed ticket #58: broken link to the instruments definition files
* Qt 5.12.4 libraries included on binary packages

Compilation minimum requirements for all platforms: CMake 3.0, Qt 5.x and
Drumstick 1.1 or later.

Please use the mailing list <[hidden email]> for
questions and comments. Thanks.

Copyright (C) 2008-2019, Pedro López-Cabanillas and others
License: GPL v3

More info
http://vmpk.sourceforge.net

Downloads
http://sourceforge.net/projects/vmpk/files/0.7.2
_______________________________________________
Linux-audio-announce mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-announce