Re: Trying to start Aeous gives me seg faults

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Trying to start Aeous gives me seg faults

David Jones
> On 09/18/2017 06:39 AM, Fons Adriaensen wrote:
>> On Mon, Sep 18, 2017 at 07:31:41AM +0200, Hermann Meyer wrote:
>>  
>>> Am 18.09.2017 um 06:44 schrieb david:
>>>> Starting Aeolus from command line returns this:
>>>>
>>>> Reading '/usr/share/aeolus/stops/Aeolus/definition'
>>>> Reading '/home/david/.aeolus-presets'
>>>> Segmentation fault
>>>
>>> First shot in such cases is remove/rename config files in home
>>> '/home/david/.aeolus-presets'
>>
>> No, this is due to recent versions of the font libs requiring
>> more stack space.
>>
>> In main.cc, line 253, increase the stack size of the interface
>> thread:
>>
>>    iface->thr_start (SCHED_OTHER, 0, 0x00020000);
>>
>> This should solve the issue.
>
> Thanks. I see that aeolus is up to 0.9.5 according to this:
>
> http://kokkinizita.linuxaudio.org/linuxaudio/downloads/index.html
>
> Line 253 in main.cc there matches your line above. So I should increase the 0x00020000? Or is that the value it should be at and my current version has something smaller?
>
> Thanks.

Sorry for delay, but I downloaded the Aeolus source from the link above and tried running make while in the source directory. I got the following error:

g++ -O3 -Wall -MMD -MP -march=native -DVERSION=\"0.9.5\" -DLIBDIR=\"/usr/local/lib64\"  -c -o main.o main.cc
main.cc:28:23: fatal error: clthreads.h: No such file or directory
compilation terminated.
<builtin>: recipe for target 'main.o' failed
make: *** [main.o] Error 1

Ideas?

Also, I can report something else weird. On my desktop machine, running Debian Testing + KXStudio repositories, Aeolus starts up and runs fine. On my laptop, also running Debian Testing + KXStudio repositories, Aeolus dies with the seg fault reported above.

David W. Jones
[hidden email]
authenticity, honesty, community
http://dancingtreefrog.com
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|

Re: Trying to start Aeous gives me seg faults

Ralf Mardorf
On Sun, 1 Oct 2017 8:10:48 +0000, [hidden email] wrote:
>fatal error: clthreads.h: No such file or directory

[rocketmouse@archlinux ~]$ pacman -Qi clthreads | head -5
Name            : clthreads
Version         : 2.4.0-2
Description     : C++ wrapper library around the POSIX threads API
Architecture    : x86_64
URL             : http://kokkinizita.linuxaudio.org/linuxaudio/
[rocketmouse@archlinux ~]$ pacman -Ql clthreads
clthreads /usr/
clthreads /usr/include/
clthreads /usr/include/clthreads.h
clthreads /usr/lib/
clthreads /usr/lib/libclthreads.so
clthreads /usr/lib/libclthreads.so.2
clthreads /usr/lib/libclthreads.so.2.4.0

You could download it from
http://kokkinizita.linuxaudio.org/linuxaudio/downloads/index.html
http://kokkinizita.linuxaudio.org/linuxaudio/downloads/clthreads-2.4.0.tar.bz2

Btw. Fons, it would be nice if you could add signed checksums ;).
                                             ^^^^^^
--
Guerilla Open Access Manifesto:
https://archive.org/stream/GuerillaOpenAccessManifesto/Goamjuly2008_djvu.txt
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|

Re: Trying to start Aeous gives me seg faults

Francesco Ariis
In reply to this post by David Jones
On Sun, Oct 01, 2017 at 08:10:48AM +0000, [hidden email] wrote:
> Also, I can report something else weird. On my desktop machine, running Debian Testing + KXStudio repositories, Aeolus starts up and runs fine. On my laptop, also running Debian Testing + KXStudio repositories, Aeolus dies with the seg fault reported above.

Maybe one box is JACK based and the other one is ALSA based?
In this case, aeolus -A would fix it.
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|

Re: Trying to start Aeous gives me seg faults

David Jones
On 10/01/2017 05:37 AM, Francesco Ariis wrote:
> On Sun, Oct 01, 2017 at 08:10:48AM +0000, [hidden email] wrote:
>> Also, I can report something else weird. On my desktop machine, running Debian Testing + KXStudio repositories, Aeolus starts up and runs fine. On my laptop, also running Debian Testing + KXStudio repositories, Aeolus dies with the seg fault reported above.
>
> Maybe one box is JACK based and the other one is ALSA based?
> In this case, aeolus -A would fix it.

Thanks but they both use JACK.

I think Fons is right, it's something to do with memory allocation in
the code.

--
David W. Jones
[hidden email]
authenticity, honesty, community
http://dancingtreefrog.com
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|

Re: Trying to start Aeous gives me seg faults

David Jones
In reply to this post by Ralf Mardorf
On 10/01/2017 01:50 AM, Ralf Mardorf wrote:

> On Sun, 1 Oct 2017 8:10:48 +0000, [hidden email] wrote:
>> fatal error: clthreads.h: No such file or directory
>
> [rocketmouse@archlinux ~]$ pacman -Qi clthreads | head -5
> Name            : clthreads
> Version         : 2.4.0-2
> Description     : C++ wrapper library around the POSIX threads API
> Architecture    : x86_64
> URL             : http://kokkinizita.linuxaudio.org/linuxaudio/
> [rocketmouse@archlinux ~]$ pacman -Ql clthreads
> clthreads /usr/
> clthreads /usr/include/
> clthreads /usr/include/clthreads.h
> clthreads /usr/lib/
> clthreads /usr/lib/libclthreads.so
> clthreads /usr/lib/libclthreads.so.2
> clthreads /usr/lib/libclthreads.so.2.4.0
>
> You could download it from
> http://kokkinizita.linuxaudio.org/linuxaudio/downloads/index.html
> http://kokkinizita.linuxaudio.org/linuxaudio/downloads/clthreads-2.4.0.tar.bz2

The version I installed from Debian Testing is 2.4.0-7.

Working with Fons, I have it running, but it displays no stops and makes
no sound.

--
David W. Jones
[hidden email]
authenticity, honesty, community
http://dancingtreefrog.com
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user