Scarlett 18i8 3rd Gen - insistent click noises but no xruns

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Scarlett 18i8 3rd Gen - insistent click noises but no xruns

marcod
Hi all,

I've originally posted this issue on the Linux Musicians forum, and despite
having received several suggestions, we were not able to solve the issue.
(for those interested in the previous thread:
https://linuxmusicians.com/viewtopic.php?f=27&t=20629)

I'm an experienced Linux Audio user and have utilised a fair amount of
soundcards on Linux systems.
I've read most of the Scarlett 2nd Gen. post I could find here and
elsewhere, and noticed there's little info about the 3rd Gen.
I'm taking this chance to share my experience with a 18i8 3rd Gen. and see
if my problem can be solved.

SPECS:
I'm on a DELL M4800 Precision, Linux Mint 19 with Cinnamon, kernel
4.15.0-66-lowlatency.
Soundcard: Focusrite Scarlett 18i8 3rd Generation. I'm in the audio group
and the audio group has access to RT.

After the necessary tricks to force the soundcard out of MSD Storage mode,
now the device is recognised by and fully functioning with both Pulseaudio
and Jackd. However.....

PROBLEM:
When using the soundcard (either via Pulseaudio or via Qjackctl), I can hear
click noises at almost regular intervals. The clicks vary in loudness (some
are very loud, other almost unnoticeable). Independently from the CPU or
Disk usage, the clicks are always there, making the soundcard effectively
unusable.

Interestingly, when using the card via Qjackctl I see no XRuns, but I do
clearly hear the clicks.

ACTIONS TAKEN:
I excluded a defected soundcard, broken USB cable or USB port issues
(sometimes USB3 can cause troubles) because when using the soundcard on a
Windows partition on the same computer, the sound is clean, no clicks.
Although, perhaps I'm missing something here.

Running realTimeConfigQuickScan gives me a mostly positive check, the only
"not good" items are the following ones:
- Checking swappiness... 60
- Checking checking sysctl inotify max_user_watches... < 524288
- Checking access to the high precision event timer... not readable
- Checking access to the real-time clock... not readable
- Kernel with Real-Time Preemption... not found

these "not good" items have always been the same on my laptop, and they
never gave me troubles with two other Scarlett soundcards. I've also read on
the ConfigQuickScan page that - except Swappiness - the other items are not
so important these days any more. So I'm assuming the clicks with the
Scarlett 18i8 3rd Gen. are likely not related to any of those items. But I
may be wrong...

I've also tested with 48000 and 44100, no difference.

Does anyone have any hint on the issue? Or other things I could check?

thanks in advance,



--
Sent from: http://linux-audio.4202.n7.nabble.com/linux-audio-user-f5.html
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|

Re: Scarlett 18i8 3rd Gen - insistent click noises but no xruns

Peter-2
Dear Marcod,

I can't help you with your problem, but since it is a Scarlett 18i8 3rd Gen
you might be interested in the following thread, concerning a 18i8 3rd Gen driver
beyond usb audio class compliance:
< https://linuxmusicians.com/viewtopic.php?f=6&t=20669 >

Best regards,
Peter




Am 12.11.19 um 14:26 schrieb marcod:

> Hi all,
>
> I've originally posted this issue on the Linux Musicians forum, and despite
> having received several suggestions, we were not able to solve the issue.
> (for those interested in the previous thread:
> https://linuxmusicians.com/viewtopic.php?f=27&t=20629)
>
> I'm an experienced Linux Audio user and have utilised a fair amount of
> soundcards on Linux systems.
> I've read most of the Scarlett 2nd Gen. post I could find here and
> elsewhere, and noticed there's little info about the 3rd Gen.
> I'm taking this chance to share my experience with a 18i8 3rd Gen. and see
> if my problem can be solved.
>
> SPECS:
> I'm on a DELL M4800 Precision, Linux Mint 19 with Cinnamon, kernel
> 4.15.0-66-lowlatency.
> Soundcard: Focusrite Scarlett 18i8 3rd Generation. I'm in the audio group
> and the audio group has access to RT.
>
> After the necessary tricks to force the soundcard out of MSD Storage mode,
> now the device is recognised by and fully functioning with both Pulseaudio
> and Jackd. However.....
>
> PROBLEM:
> When using the soundcard (either via Pulseaudio or via Qjackctl), I can hear
> click noises at almost regular intervals. The clicks vary in loudness (some
> are very loud, other almost unnoticeable). Independently from the CPU or
> Disk usage, the clicks are always there, making the soundcard effectively
> unusable.
>
> Interestingly, when using the card via Qjackctl I see no XRuns, but I do
> clearly hear the clicks.
>
> ACTIONS TAKEN:
> I excluded a defected soundcard, broken USB cable or USB port issues
> (sometimes USB3 can cause troubles) because when using the soundcard on a
> Windows partition on the same computer, the sound is clean, no clicks.
> Although, perhaps I'm missing something here.
>
> Running realTimeConfigQuickScan gives me a mostly positive check, the only
> "not good" items are the following ones:
> - Checking swappiness... 60
> - Checking checking sysctl inotify max_user_watches... < 524288
> - Checking access to the high precision event timer... not readable
> - Checking access to the real-time clock... not readable
> - Kernel with Real-Time Preemption... not found
>
> these "not good" items have always been the same on my laptop, and they
> never gave me troubles with two other Scarlett soundcards. I've also read on
> the ConfigQuickScan page that - except Swappiness - the other items are not
> so important these days any more. So I'm assuming the clicks with the
> Scarlett 18i8 3rd Gen. are likely not related to any of those items. But I
> may be wrong...
>
> I've also tested with 48000 and 44100, no difference.
>
> Does anyone have any hint on the issue? Or other things I could check?
>
> thanks in advance,
>
>
>
> --
> Sent from: http://linux-audio.4202.n7.nabble.com/linux-audio-user-f5.html
> _______________________________________________
> Linux-audio-user mailing list
> [hidden email]
> https://lists.linuxaudio.org/listinfo/linux-audio-user
>
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|

Re: Scarlett 18i8 3rd Gen - insistent click noises but no xruns

marcod
Hi Peter,

thanks for the pointer.
Yes I had seen the post and I'm waiting for the new driver to come out and
see if it solves anything.

I hope it is indeed just a matter of driver, because I'm a bit out of
options in terms of debugging.

best,



--
Sent from: http://linux-audio.4202.n7.nabble.com/linux-audio-user-f5.html
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user