Quantcast

can't record from qsynth in Rosegarden

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

can't record from qsynth in Rosegarden

linux_matt
This post was updated on .
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can't record from qsynth in Rosegarden

Ralf Mardorf
On Mon, 11 Feb 2013 14:20:20 +0100, linux_matt  
<[hidden email]> wrote:

> I have followed the instructions for recording to Rosegarden audio from
> Rosegarden midi but can't get this to work. The instructions on the
> Rosegarden site indicate that Qsynth output ports should be connected to  
> the
> Rosegarden Record In port. I have tried this under the ALSA tab and also
> under the MIDI tab (using a2jmidid to make the MIDI ports visible).  The
> only WAV recording I can get to work is the Gnome sound recorder which  
> uses
> some form of system audio capture (which I can't get to work through jack
> either into Rosegarden). Possibly this is connected to Pulseaudio?  
> (which is
> the only driver which works with Qsynth on my setup). The midi sound  
> output
> itself from Rosegarden works great
> <http://linux-audio.4202.n7.nabble.com/file/n82124/snapshot1.jpeg>

So if you use fluidsynth-dssi (the plugin) instead of Qsynth (a GUI for  
fluidsynth) it does work?
The screenshot perhaps does show that you connected Rosegarden -> Qsynth?  
What are the MIDI channel settings for Rosegarden's MIDI tracks? Can you  
send MIDI notes by a virtual keyboard or a hardware keyboard directly to  
Qsynth, instead of using Rosegarden? Does this work?
_______________________________________________
Linux-audio-user mailing list
[hidden email]
http://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can't record from qsynth in Rosegarden

Ralf Mardorf
On Mon, 11 Feb 2013 14:30:33 +0100, Ralf Mardorf  
<[hidden email]> wrote:

> On Mon, 11 Feb 2013 14:20:20 +0100, linux_matt  
> <[hidden email]> wrote:
>> I have followed the instructions for recording to Rosegarden audio from
>> Rosegarden midi but can't get this to work. The instructions on the
>> Rosegarden site indicate that Qsynth output ports should be connected  
>> to the
>> Rosegarden Record In port. I have tried this under the ALSA tab and also
>> under the MIDI tab (using a2jmidid to make the MIDI ports visible).  The
>> only WAV recording I can get to work is the Gnome sound recorder which  
>> uses
>> some form of system audio capture (which I can't get to work through  
>> jack
>> either into Rosegarden). Possibly this is connected to Pulseaudio?  
>> (which is
>> the only driver which works with Qsynth on my setup). The midi sound  
>> output
>> itself from Rosegarden works great
>> <http://linux-audio.4202.n7.nabble.com/file/n82124/snapshot1.jpeg>
>
> So if you use fluidsynth-dssi (the plugin) instead of Qsynth (a GUI for  
> fluidsynth) it does work?
> The screenshot perhaps does show that you connected Rosegarden ->  
> Qsynth? What are the MIDI channel settings for Rosegarden's MIDI tracks?  
> Can you send MIDI notes by a virtual keyboard or a hardware keyboard  
> directly to Qsynth, instead of using Rosegarden? Does this work?

:D

Now I see ... you connected Qsynth -> Rosegarden. Thats wrong! MIDI isn't  
an audio output, it only does send remote data to play a note or another  
event, you need to connect ALSA (MIDI) Rosegarden -> Qsynth to remote  
control the synth and you need to connect ALSA audio Qsynth -> audio card  
or what ever.
_______________________________________________
Linux-audio-user mailing list
[hidden email]
http://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: can't record from qsynth in Rosegarden

Ralf Mardorf
On Mon, 11 Feb 2013 14:34:15 +0100, Ralf Mardorf  
<[hidden email]> wrote:

> On Mon, 11 Feb 2013 14:30:33 +0100, Ralf Mardorf  
> <[hidden email]> wrote:
>
>> On Mon, 11 Feb 2013 14:20:20 +0100, linux_matt  
>> <[hidden email]> wrote:
>>> I have followed the instructions for recording to Rosegarden audio from
>>> Rosegarden midi but can't get this to work. The instructions on the
>>> Rosegarden site indicate that Qsynth output ports should be connected  
>>> to the
>>> Rosegarden Record In port. I have tried this under the ALSA tab and  
>>> also
>>> under the MIDI tab (using a2jmidid to make the MIDI ports visible).  
>>> The
>>> only WAV recording I can get to work is the Gnome sound recorder which  
>>> uses
>>> some form of system audio capture (which I can't get to work through  
>>> jack
>>> either into Rosegarden). Possibly this is connected to Pulseaudio?  
>>> (which is
>>> the only driver which works with Qsynth on my setup). The midi sound  
>>> output
>>> itself from Rosegarden works great
>>> <http://linux-audio.4202.n7.nabble.com/file/n82124/snapshot1.jpeg>
>>
>> So if you use fluidsynth-dssi (the plugin) instead of Qsynth (a GUI for  
>> fluidsynth) it does work?
>> The screenshot perhaps does show that you connected Rosegarden ->  
>> Qsynth? What are the MIDI channel settings for Rosegarden's MIDI  
>> tracks? Can you send MIDI notes by a virtual keyboard or a hardware  
>> keyboard directly to Qsynth, instead of using Rosegarden? Does this  
>> work?
>
> :D
>
> Now I see ... you connected Qsynth -> Rosegarden. Thats wrong! MIDI  
> isn't an audio output, it only does send remote data to play a note or  
> another event, you need to connect ALSA (MIDI) Rosegarden -> Qsynth to  
> remote control the synth and you need to connect ALSA audio Qsynth ->  
> audio card or what ever.

My apologies :(, the screenshot is displayed very bad on my browser, it  
seems to be correctly connected.
_______________________________________________
Linux-audio-user mailing list
[hidden email]
http://lists.linuxaudio.org/listinfo/linux-audio-user
Loading...