zita-a2j Pegging CPU

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

zita-a2j Pegging CPU

Scott Cazan
Hello,

I've been having this issue with zita-a2j launching into 100% CPU usage fairly frequently when I am running Carla, one VST (Audeze Reveal Plugin), and using Ubuntu Studio 19.04.

Has anyone else seen this kind of behavior before and knows what might be happening?

--

_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|

Re: zita-a2j Pegging CPU

Len Ovens
On Tue, 8 Oct 2019, Scott Cazan wrote:

> I've been having this issue with zita-a2j launching into 100% CPU usage fairly
> frequently when I am running Carla, one VST (Audeze Reveal Plugin), and using
> Ubuntu Studio 19.04.
>
> Has anyone else seen this kind of behavior before and knows what might be
> happening?

I certainly wish I knew what was happening. But yes I have seen similar
things normally if the USB device zita-ajbridge happens to be using at the
time, is unplugged. Restarting Jack always fixes it for me.

If you are using ubuntustudio-controls to run jack, I would suggest filing
a bug against that package as development is ongoing. Controls does send a
SIGKILL to the PID of the zita-ajbridge if it detects the removal of a USB
device but that does not always seem to be effective. If there is a better
way to terminate zita-ajbridge I too would like to know.

So of course sitting here and maddly plugging and unplugging a USB device
does not trigger this behaviour while I watch :P  This may be because I am
using a newer version of ubuntustudio-controls than you are.

zita-ajbridge does not seem to detect a vanished device itself. I would
guess alsa does not have a callback for that.

--
Len Ovens
www.ovenwerks.net
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user
Reply | Threaded
Open this post in threaded view
|

Re: zita-a2j Pegging CPU

Len Ovens
On Tue, 8 Oct 2019, Len Ovens wrote:

> On Tue, 8 Oct 2019, Scott Cazan wrote:
>
>> I've been having this issue with zita-a2j launching into 100% CPU usage
>
> If you are using ubuntustudio-controls to run jack, I would suggest filing
> a bug against that package as development is ongoing. Controls does send a
> SIGKILL to the PID of the zita-ajbridge if it detects the removal of a USB
> device but that does not always seem to be effective. If there is a better
> way to terminate zita-ajbridge I too would like to know.

Also noted while playing around, it does not seem to matter if the device
is removed or not, sending either SIGKILL or SIGTERM does not fully get
rid of zita-ajbridge:

$ ps x |grep zita
27584 pts/5    Z+     0:00 [zita-j2a] <defunct>
27585 pts/5    Z+     0:00 [zita-a2j] <defunct>

one was killed with SIGTERM and the other with SIGKILL

Both of these vanish on stopping jackd or starting another zita-ajbridge.

--
Len Ovens
www.ovenwerks.net
_______________________________________________
Linux-audio-user mailing list
[hidden email]
https://lists.linuxaudio.org/listinfo/linux-audio-user